Опубликовано: 25.06.2010 Последняя правка: 10.12.2015
HTMLXHTML
IEChromeFireFoxOperaSafari

Атрибут autocomplete

Атрибут autocomplete, тега <INPUT>, разрешает или запрещает автозаполнение текстового поля формы, только для type="text" или "password". Многие браузеры используют автозаполнение текстовых полей, что позволяет пользователям не вводить еще раз текст, который уже вбивался ими ранее. Причем, порой, хранят браузеры эти данные в открытом виде, в каком-нибудь своем файле. Это конечно очень удобно, но не всегда бывает к месту, особенно, если на вашем сайте есть поля для ввода конфиденциальной информации (номера кредитных карт, пароли и т.д.). В таком случае атрибут autocomplete будет, как нельзя кстати.

Если вы хотите запретить автозаполнение для всех текстовых полей формы, то можно использовать атрибут autocomplete тега <FORM>.

Значения

Значением атрибута является одно из ключевых слов.

Значение по умолчанию: Зависит от типа и настроек браузера.

Синтаксис

<input autocomplete="значение">

Обязательный атрибут: нет.

Пример HTML: применение атрибута autocomplete

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">
<html>
 <head>
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8">
  <title>seodon.ru - Тег FIELDSET, атрибут autocomplete</title>
 </head>
 <body>
  <form action="files/questions.php">
   <p><input type="text" name="name" size="30">Введите логин</p>
   <p><input type="password" name="password" size="30" autocomplete="off">Введите пароль</p>
   <p><input type="text" name="creditcard" size="20" autocomplete="off">Номер кредитной карты</p>
   <p><input type="submit" name="ok" value="Отправить"></p>
  </form> 
 </body>
</html>

Результат примера

Поддержка версиями HTML

Версия:HTML 4.01HTML 5XHTML 1.0XHTML 1.1
Поддержка:ЧастичноДаЧастичноНет

Атрибута autocomplete нет в спецификациях HTML 4.01 и XHTML, поэтому если его использовать будет невалидный код.

Поддержка браузерами

Браузер:Internet ExplorerGoogle ChromeMozilla FirefoxOperaSafari
Версия:6.0 и выше2.0 и выше2.0 и выше9.2 и выше3.1 и выше
Поддержка:ДаДаДаНетДа